互动直播之即时通讯swoole安装教程(Centos篇A)



Centos前置环境

安装之前请确认如下内容是否为指定版本、已安装:

php-5.3.10 或更高版本,建议使用PHP 5.4及以上版本:php -v

gcc-4.4 或更高版本:rpm -qa|grep gcc

make :rpm -qa|grep make

autoconf :rpm -qa|grep autoconf

安装步骤

 

(1)下载swoole安装包到本地(下载到root家目录下)

cd /root/

wget https://github.com/swoole/swoole-src/archive/v1.9.13.tar.gz

(2)解压并进入该目录

tar zxf v1.9.13.tar.gz

cd swoole-src-1.9.13/

(3)使用phpize来生成php编译配置(phpize路径在php安装目录的bin目录下,视实际安装路径而定)

/www/wdlinux/nginx_php/bin/phpize

出现类似以下内容就说明成功:

Configuring for:

PHP Api Version: 20121113

Zend Module Api No: 20121212

Zend Extension Api No: 220121212

注意:这里有使用yum安装的php环境,直接运行phpize,可能会出现如下错误:

Can't find PHP headers in /usr/include/php

The php-devel package is required for use of this command.

这是因为现在安装的php库不匹配现在的php版本,根据php -v得知当前版本,并依据版本yum安装php-devel,例如:yum install -y php55w-devel

(4)使用./configure来做编译配置检测,没有出现error就说明成功

./configure --with-php-config=/www/wdlinux/nginx_php/bin/php-config --enable-openssl

注意:php-config的路径视实际情况而定。如果yum安装的php环境,只需要直接运行./configure --enable-openssl

(5)使用make进行编译

make

(6)使用make install进行安装

make install

没有出现error说明没有问题,make install成功后会生成一个Installing shared extensions及路径。

例如:Installing shared extensions: /usr/lib64/php/modules/

说明在这个路径下生成了swoole.so

把 extension = /usr/lib64/php/modules/swoole.so

复制到php.ini文件中(php.ini文件可以在phpinfo中或者使用php -i |grep php.ini命令查看)

(7)重启php服务,使用phpinfo或者php -m查看是否安装成功

(8)下载socket.config.php文件: http://pan.baidu.com/s/1ge9cLLT 密码:6a0p 
     按照文件中的说明修改好后上传到服务器站点根目录下面addons/ewei_shopv2/core/socket目录下

(9)使用php命令在服务器执行server.php文件,php命令的路径跟上面phpize同属bin目录下面。

例如:/www/wdlinux/nginx_php/bin/php   站点根目录/addons/ewei_shopv2/core/socket/server.php

(10)检查是否成功:ps -ef|grep PHP

(11)额外说明:如何重启该服务?

    首先通过ps -ef|grep PHP找到父进程id是1的进程,如下图:

blob.png

     使用kill命令杀死该进程 : kill   1607

     再执行第(10)步启动





此页内容是否有用?请给出您的反馈和评价: